Martin M-PC failed to open, reinstall also failing, trying to locate data for backup


recently I couldn’t open my Martin M-PC installation anymore.
So I simply tried reinstalling it, but when reinstalling I get the error 1720 and cannot reinstall.
Now I read some suggestions in a couple of threads here on how to solve that. So far none of them worked(like running as Admin and other things like that).
I am about to try using the MPC cleaner tool, but before I do that I want to save my data.
It’s like Martin M-PCs data is all over the place on my harddrive and not sure exactly what I need to backup before running that tool. I obviously would like to keep my settings, shows and my fixture library with the fixtures I created.
I found my shows in a folder ‘username/Documents/My Maxxyz Files’.
But I haven’t been able to locate the fixtures I created. I found a fixture library in ‘C:\ProgramData\Martin Professional’, but that doesn’t contain any of my fixtures. Where can I find them? Or did the failed installation process somehow overwrite my fixtures already?


it looks like running the cleaner and admin mode is the solution here.

The showfile you saved will be in “C:\Users<Username>/Documents/My Maxxyz Files”

The user fixtures you created will be in the same folder if you exported them, otherwise they can be as XML files in
C:\Users\Public\Documents\Maxxyz Files\Fixture Library



Thank you so much. I found my fixtures there.
Is there anything else I might be overlooking now, I should backup before running the cleaner?


The only possibility for problem is if you did not save the show to file. If you did then you are ready to upgrade.


Thank you. Everything worked perfectly after using the Cleanup tool. All my shows and fixtures have been saved and are working fine in my new install.



I have uninstalled the old software, installed the latest M-PC 4 times and it keeps crashing. It loads until 2D Plan when you open m-pc but then say it is not working with APPCRASH as the error.

Please help urgently

  • Restart your PC
  • Make sure not DMX USB devices are connected
  • Follow the procedure in this post
    Martin Cleanup Tool