Trouble Programming Function Keys



So I’m trying to delete a function key on my M6 but it won’t let me delete, add, or change any of the function keys. The workspace is unlocked and I’ve tried multiple show files on the console. Is there a system setting or something I am missing?

  • Software build?
  • Which F-Keys are in question?
  • How are you trying to manipulate them?


I’m on 3.71.911.0 and it’s F1-12 I have held down edit and selected them and have tried going through the M6 button on the top left to go to the functions tab. I’m trying to remove a patch window shortcut but when I try to alter any of them I cannot. I have made sure the workspace is unlocked as well


This issue is reported on the 911 Beta post…

Current one is 945… Although I will not recommend installing it on M6, due to reported show loading issues…


Gotchya thanks for the info


Please note you can also edit F-Keys via Blue Ball menu\ Function keys

You may also take a look at the next Beta 919, where this issue should have been fixed